Recurring Orders not Processing
Incident Report for Subscribe Pro
Resolved
This incident has been resolved.
Posted 26 days ago. Jul 30, 2019 - 14:53 EDT
Monitoring
We have fixed the issue causing some recurring orders not to be processed. We will continue to monitor for any further issues.
Posted 26 days ago. Jul 30, 2019 - 14:14 EDT
Investigating
We are investigating reports that some recurring orders are not being processed as expected.
Posted 26 days ago. Jul 30, 2019 - 14:08 EDT