Currently experiencing partial downtime

Incident Report for Subscribe Pro

Resolved

Full service has been restored.
Posted Oct 01, 2020 - 06:40 EDT

Investigating

Our Merchant App and API are currently experiencing partial downtime due to a long running database update.
Posted Oct 01, 2020 - 06:17 EDT