Order Jobs Delayed
Incident Report for Subscribe Pro
Resolved
We have determined the cause of the slow running recurring order processing jobs and have taken steps to make the system run smoothly in the short term. We will be taking additional steps to prevent this from occurring in the long term, as well.

Order generation has been turned back on, and our system appears to be caught up at this time. Please reach out to support@subscribepro.com if you continue to notice any issues or delays with order processing.
Posted about 1 year ago. Jul 05, 2018 - 14:13 EDT
Update
We are continuing to investigate the issue with slow recurring order job processing. We have disabled order jobs while we look into this issue further.
Posted about 1 year ago. Jul 05, 2018 - 10:16 EDT
Investigating
We are currently investigating an issue with delayed order processing for recurring orders.
Posted about 1 year ago. Jul 05, 2018 - 09:11 EDT