Slow and Delayed Recurring Order Processing
Incident Report for Subscribe Pro
Resolved
The problem with slow and delayed subscription processing has been resolved. We are still investigating the root cause.
Posted over 1 year ago. Feb 28, 2018 - 13:56 EST
Investigating
We are investigating slow and delayed recurring order processing across all Subscribe Pro environments. We are investigating the issue and will report when everything is back to normal.
Posted over 1 year ago. Feb 28, 2018 - 12:13 EST