Partial Outage
Incident Report for Subscribe Pro
Resolved
The partial outage of recurring order processing has been resolved.
Posted 6 months ago. Apr 14, 2019 - 11:46 EDT
Monitoring
We have identified the issue and put a fix into place. We will continue to monitor to ensure everything continues to process as expected. If your accounts' subscriptions were delayed, they should process soon.
Posted 6 months ago. Apr 14, 2019 - 11:08 EDT
Investigating
We are currently investigating a partial outage of our recurring order processing.
Posted 6 months ago. Apr 14, 2019 - 10:41 EDT