API Authentication Degraded
Incident Report for Subscribe Pro
Resolved
This incident has been resolved.
Posted almost 2 years ago. Jan 10, 2017 - 07:24 EST
Monitoring
We have some customers who are experiencing API authentication issues. In all cases this should be resolved by flushing Magento caches.

We deployed a change to our platform this morning which upgraded the OAuth2 authentication system. This system is currently used by our Magento 1 extension. The upgrade invalidated all existing OAuth access tokens.

The expectation was that the invalidated access tokens were cached for no more than 5 minutes by Magento 1 clients. However it appears that in a few cases, access tokens are cached longer.

The issue should be resolved by flushing all caches in the Magento admin panel, specifically the 2 Subscribe Pro related caches.
Posted almost 2 years ago. Jan 10, 2017 - 06:09 EST