Slow Platform Response / Partial Outage
Incident Report for Subscribe Pro
Postmortem

We investigated the root cause on Monday’s partial outage. In short some long running reporting queries were able to overwhelm database connections and make the platform unresponsive. Today we have implemented a system to stop long running queries and prevent them from impacting overall system performance. With this new system, an outage similar to Monday’s will no longer be possible.

Posted 6 months ago. Aug 01, 2018 - 17:16 EDT

Resolved
This issue causing the partial outage of our Web UI and API has been resolved. The issue was related to our tabular reporting, which has been temporarily disabled until the root issue is addressed.
Posted 6 months ago. Jul 30, 2018 - 17:35 EDT
Monitoring
We believe the issue is resolved. We will continue monitoring and provide a post-mortem once we fully understand the issue.
Posted 6 months ago. Jul 30, 2018 - 16:01 EDT
Investigating
We are currently investigating a partial outage of the Subscribe Pro Web UI and API.
Posted 6 months ago. Jul 30, 2018 - 15:38 EDT
This incident affected: Subscribe Pro Application (API | api.subscribepro.com, Management Portal | platform.subscribepro.com).