Amazon S3 Issues
Incident Report for Subscribe Pro
Resolved
As of 5:08pm ET AWS has considered the issues resolved.
Posted 11 months ago. Feb 28, 2017 - 19:20 EST
Monitoring
Due to currently ongoing issues with the Amazon S3 service, specifically targeting the us-east-1 server, some impact may be seen in our platform. In particular, we have noticed that some transactional emails are failing to be sent. We will continue to monitor the situation and provide updates as they become available.

You can find more information at the Amazon AWS status site, here: https://status.aws.amazon.com/
Posted 11 months ago. Feb 28, 2017 - 15:41 EST